Debian 9 is no longer supported. See here: https://wiki.debian.org/LTS
Please remove it from the list of droplet images.